Kauf doch deine Geschenke über diesen Link und unterstütze damit jogmap.

Topangebot der Woche

So liebe Jogmapper,

gestern habe ich eine kleine Anleitung zur Erstellung eines Backups der Läufe geschrieben:

Siehe http://www.jogmap.de/civic4/?q=node/436502

Auf Facebook wurde netterweise das Wort "Pivot" angesprochen, was im Excel-Jargon sofort die Assoziation weckt: AUSWERTUNG. Dazu möchte ich nun zunächst eine kleine Übersicht/Anleitung geben, wie man aus den wenigen Backup-Daten alle möglichen Informationen "rauskitzeln" kann, die anschließend zur Auswertung bereitstehen.

Wir haben nun also (vermutlich) folgende Spalten in Excel:

(1) Name des Laufs (2) Distanz (3) Dauer (4) Datum (5) Uhrzeit (6) Pace (7) Kalorien.

Damit können wir nun die Spalten gruppiert auswerten, zum Beispiel: Wieviele Kilometer bin ich in welchem Monat gelaufen? An welchen Wochentagen laufe ich mehr, an welchen weniger? Zu welchen Uhrzeiten bin ich besonders schnell?

Wir müssen aber erst einige Felder aufbereiten. Zum Glück haben wir die wesentlichen Informationen bereits:

- Wochentag. Bei Excel gibt es die Funktion "WOCHENTAG". Wenn jetzt in der Excel-Zelle "A1" das Datum steht, erhalten wir den Wochentag, in dem wir in einer beliebigen Zelle eingeben: =WOCHENTAG(A1) --> Nun bitte per Rechtsklick auf die erstellte Zelle gehen, dann auf "Zellen formatieren", dann auf die Registerkarte "Zahlen", dann auf "Benutzerdefiniert" und bei Typ "TTTT" eintragen. Nun sollten automatisch der Wochentag als Text angezeigt werden.

- Monat und Jahr. Das ist noch einfacher. Wenn in der Zelle "A1" das Datum steht, bitte für den Monat in eine beliebige Zelle eintragen: =TEXT(A1; "MMMM") und für das Jahr: =TEXT(A1; "JJJJ") --> Nun werden Monat und Jahr explizit ausgewiesen.

- Geschwindigkeit in km/h: Wenn in A1 die Distanz steht und in B1 die Dauer (in Stunden:Minuten:Sekunden), dann bitte in das gewünschte Feld, in dem die Geschwindigkeit angezeigt werden soll, eintragen: =A1/(B1*24) --> Dann auf "Zellen formatieren", "Zahlen", "Zahl", "Dezimalstellen: 2". Damit sollte dioe Geschwindigkeit in km/h ausgewiesen sein. Die oben genannte Formel besagt im Grunde nichts Anderes als: Kilometer/Stunden, wobei die Stunden aufgrund des Excel-Formats (das die Zeit als Bruchteil eines Tages ausweist) mit 24 multipliziert werden muss. Das aber nur am Rande.

- Tageszeit. Nun wird es noch komplizierter, denn dafür gibt es keine spezielle Formel. Gehen wir davon aus, dass in Zelle A1 die Uhrzeit steht, in der ein Lauf begonnen wurdew, dann kann mit folgender Formelk zwischen "morgens" (0-12 Uhr), "nachmittags" (12-18 Uhr) und "abends" (nach 18 Uhr) unterschieden werden: =WENN((A1*24)<12;"morgens"; WENN(UND((A1*24) > 12; (A1*24) < 18);"nachmittags";"abends")) --> das lässt sich auch noch weiter differenzieren, aber dann werden die Bedingungen ungleich komplizierter. Wenn aber jemand eine einfachere Lösung kennt, würde ich mich darüber freuen.

- Dauer des Laufes gruppiert. Man kann sich ausweisen lassen, wie lange ein Lauf "ungefähr" gedauert hat. Wenn in Zelle A1 die Dauer des Laufes steht, dann kann man mit folgendem Befehl die Läufe in "unter einer Stunde", "zwischen einer und zwei Stunden" und "mehr als zwei Stunden" differenzieren. Für weitere Differenzierungen gilt das Gleiche wie bei der Tageszeit: =WENN((A1*24)<1;"unter einer Stunde"; WENN(UND((A1*24) > 1; (A1*24) < 2);"zwischen einer und zwei Stunden";"mehr als zwei Stunden"))

Diese Daten stehen nun für Auswertungen in Pivot-Tabellen und -graphiken zur Verfügung. Dazu kommen wir beim nächsten Mal. Würde mich über Rück- und Erfolgsmeldungen freuen!

5
Gesamtwertung: 5 (4 Wertungen)

Das mit dem Wochentag geht doch genauso ...

... wie bei Jahr und Monat: =TEXT(A1;"TTTT"), oder wer die Abkürzungen mehr mag, verwendet nur "TTT". Dann steht da z.B. nicht "Montag", sondern nur "Mo"
;-)

Danke!

Super! Wusste ich nicht. Dachte, bei TTTT werden nur die Ziffern angezeigt, z.B. bei 23.03.2015 "23". So isses natürlich viel einfacher!

Darstellungsoptionen

Wählen Sie hier Ihre bevorzugte Anzeigeart für Kommentare und klicken Sie auf „Einstellungen speichern“ um die Änderungen zu übernehmen.

Google Links